Sysadmin Ga perlu Coding, Yakin?

Ketika saya kuliah, saya bercita cita menjadi admin jaringan. Inginnya kerja di data center, webhosting, ISP atau Google. Alasannya saya anggap jadi admin tingkat stressnya jauh dibawah programer. Selain itu, Admin jaringan adalah pekerjaan yang jauh dari code program atau script yang bikin pusing. Saya yakin sebagian pembaca pasti berpikiran yang sama bukan? apalagi kalau jurusannya Teknik informatika. Ternyata, pandangan bahwa syadmin ga perlu belajar coding perlu di kaji ulang. Jika anda ingin bercita cita bekerja di jaringan dengan harapan lepas dari coding, sepertinya anda perlu melihat lebih dalam tentang sysAdmin. Pingin tau lebih jauh baca terus tulisan ini.

Admin Router

Menjadi admin router yang emmakai Juniper, Cisco atau Mikrotik mengharuskan kita memahami perintah perintah Command line (CLI). Kadang, ada perintah perintah yang dilakukan berulang ulang dan tidak efekif kalau dilakukan secara manual. Nah, disini baru anda ‘dipaksa’ coding untuk menulis script otomatisasi. kita lihat beberapa script dibawah ini .

Mikrotik script

berikut ini contoh skript untuk mengecek dan melimit bandwidth

:foreach i in=[/interface find] do={
    /interface monitor-traffic $i once do={
        :if ($"received-bits-per-second" > 0 ) do={
            :local tmpIP [/ip address get [/ip address 
find interface=$i] address] ;
#            :log warning $tmpIP ;
            :for j from=( [:len $tmpIP] - 1) to=0 do={
                :if ( [:pick $tmpIP $j] = "/") do={
                    /queue simple a
dd name=$i max-limit=256000/256000 
dst-address=[:pick $tmpIP 0 $j] ;
                } 
            }
        }
    }
}

Cisco Script

Untuk Cisco script, silahkan lihat contohnya disini .

Admin Sever Linux/Unix/Windows

Menangani server juga tidak bisa lepas dari script, Termasuk Windows. Di Linux, anda harus belaja Bash Script /shell script sedangkan Admin WIndows harus mempelajari Batch Script atau WIndows Power Shell. Berikut ini contoh kodenya/

Linux Shell Script

Berikut ini adalah contoh shell script untuk menambah user kedalam sistem

!/bin/bash
# Script to add a user to Linux system
if [ $(id -u) -eq 0 ]; then
	read -p "Enter username : " username
	read -s -p "Enter password : " password
	egrep "^$username" /etc/passwd >/dev/null
	if [ $? -eq 0 ]; then
		echo "$username exists!"
		exit 1
	else
		pass=$(perl -e 'print crypt($ARGV[0], "password")' $password)
		useradd -m -p $pass $username
		[ $? -eq 0 ] && echo "User has been added to system!" 
|| echo "Failed to add a user!"
	fi
else
	echo "Only root may add a user to the system"
	exit 2
fi

Windows Powershell

Berikut ini adalah contoh Script powershell di Windows Server

filter FilterExcludeTree()
{
  $target = $_
  Coalesce-Args $Path "." | % {
    $canonicalPath = (Get-Item $_).FullName
    if ($target.FullName.StartsWith($canonicalPath)) {
      $pathParts = 
$target.FullName.substring($canonicalPath.Length + 1).split("\");
      if ( ! ($excludeList | where { $pathParts -like $_ } ) )
 { $target }
    }
  }
}

Admin server Database

Menjadi admin database server seperti SQL Server atau Oracle juga ga bakal lepas dari yang namanya script. Cek contoh kode PL/SQL oracle dibawah ini.


DECLARE
   x NUMBER := 100;
BEGIN
   FOR i IN 1..10 LOOP
      IF MOD(i,2) = 0 THEN     -- i is even
         INSERT INTO temp VALUES (i, x, 'i is even');
      ELSE
         INSERT INTO temp VALUES (i, x, 'i is odd');
      END IF;
      x := x + 100;
   END LOOP;
   COMMIT;
END;

Nah, inti dari tulisan ini adalah, ANDA SALAH BESAR, jika menjadi admin akan lepas dari namanya coding atau lebih tepat scripting. Perbedaannya, code untuk admin lebih sedikit dan lebih pendek, namun coding tidak akan pernah hilang jika anda ingin menjadi profesional IT, entah admin jaringan, IT Staff ataupun programer. Selamat coding bro!

Author: Candra Adi Putra

Candra Adi Putra adalah Alumni STMIK AKAKOM Yogyakarta. Like Candralab Studio Di Facebook.

2 thoughts on “Sysadmin Ga perlu Coding, Yakin?”

Tinggalin komentar dong!